ictCanada - Corp Mail Services – Incident details

Corp Mail Services

Resolved
Operational
Started 3 months agoLasted 8 minutes

Affected

Hosting Platform

Partial outage from 2:50 PM to 2:53 PM, Operational from 2:53 PM to 2:58 PM

Corp Email

Partial outage from 2:50 PM to 2:53 PM, Operational from 2:53 PM to 2:58 PM

Updates
  • Update
    Update
    This incident has been resolved.
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating
    We are currently investigating this incident.