Verizon Voice Network Outage Nation Wide.

Resolved
Partial outage
Started about 2 years ago Lasted 1 day

Affected

ictVoIP Telecom
Numbers/DIDs
Voice
Updates
  • Resolved
    Resolved

    We acknowledge the issue is still on going and clients should refer to the link below and follow Verizon's Status Updates! https://downdetector.com/status/verizon/

  • Monitoring
    Update

    Currently monitoring.

  • Monitoring
    Monitoring

    ictCanada is aware of a nationwide outage impacting Verizon. This may cause calls to/from Verizon's network to fail. We have no insight into the cause of this issue, but are letting our customers know as a courtesy. There are no issues on the ictCanada or ictVoIP network. You can follow along here: https://downdetector.com/status/verizon/