Bell Canada PSTN Connectivity Issue on some Trunks

Resolved
Degraded performance
Started almost 2 years ago Lasted about 5 hours

Affected

ictVoIP Telecom
Voice
Updates
  • Resolved
    Resolved

    Bell fixed the core issue, and are monitoring our call flows carefully

  • Investigating
    Investigating

    We are currently investigating reports of connectivity issues with Bell Canada on some trunks.